Renders failing

Hello there,

I have just recently signed up for a piad account. I did a few test renders using the API sandbox. My test renders all worked fine, so I am trying to do renders in the production account. However, they seem to all be failing.

Please advise.
See, for example: render ID 95cea17b-df3d-4583-8aec-2eba4ffe7f94


I was able to take a look at your render and it appears to time out after 15 minutes. From our end it is giving us the following error:

DTS 34562070 < 39953070 out of order

Are you concatenating the video before you send it through to Shotstack? If so what is your process?

I’m just in the process of re-encoding your video to see whether that may be the issue.

I’ll update the thread once I’ve done a few tests.

Just tested it again with the middle bit re-encoded and it’s working nicely now. I used the following command:

ffmpeg -i banter.mp4 -c:v libx264 -crf 18 -preset slow -c:a copy banter-new.mp4

If you could let me know how you’re putting together that file I may be able to help.

We are also working on an ingestion product that will fix any of these such issues in the future. We hope to inform everyone on this product soon.

Hi dazzatron, thanks for the quick response. I think I know what was going on. I originally made the highlights in my Twitch account, and then downloaded them using yt-dlp, and then I was adding the pre and post videos using shotstack. I think that whatever Twitch is doing is a bit weird. I am going to revise my flow to not use Twitch to make highlights.

I ended up re-encoding everything in Handbrake and then re-running my render jobs. It worked great thank you. I’m excited to use more of this to generate transition and highlight videos for my livestream.

1 Like