Output video quality is not as good as original asset with HD

I’m using a template with HD output and quality High.
The output video is not as good a input asset
Can you please provide support / guidance ?

Output from shotstack:

As a new user I can not post the original video to show quality difference. On the original video we can clearly see the time and we can see more details

Are you able to post a link to the original video?

Here is the original video.
As you can see quality is much better compared to the video generated with shotshtack
Original Video:

Shotstack generated video:

Those are the m3u8 playlist files, essentially text files and will give you an error if you try to use those in an edit: Rendering failed: One or more clips is not a valid media file and could not be loaded.

You must be using an mp4 file in your edits when you send the request to our API, edit JSON or use one of our SDK’s. I know that Mux lets you create an MP4 file as well as, or instead of the m3u8 stream like this: Enable static MP4 renditions | Mux. I think you must have one of those files. Please can you send me the one you used when you submitted your render.

Or better yet, can you send me a render ID of one of your renders?

In any case, this looks like either a quality/compression setting issue or the source footage resolution is low. We should be able to fix both of those.

OK, I was able to locate your account and checked some of your edits. I can see that you are using the low.mp4 version of the file, like this one:

if you inspect that URL using our probe endpoint like this: https://api.shotstack.io/v1/probe/https%3A%2F%2Fstream.mux.com%2Fz1hpHzE0233DcvZNimxpvXE02j6eepW4UWknU7weNIe6E%2Flow.mp4

You can see that the resolution of that file is 640x360px, so it is very low resolution.

What you want to do is use the high.mp4 version provided by Mux, like this:

Inspecting this one I can see the resolution is 1280x720 (HD): https://api.shotstack.io/v1/probe/https%3A%2F%2Fstream.mux.com%2Fz1hpHzE0233DcvZNimxpvXE02j6eepW4UWknU7weNIe6E%2Fhigh.mp4

So you are using the low res video and stretching it when you render your edit resulting in low quality footage.

The solution is just to use high.mp4 file instead of low.mp4 :slightly_smiling_face:

Full details in the Mux docs again, just search for high.mp4.

1 Like

Tx for the quick and very effective feedback.
It is working as expected yet and quality is high !!

A sample of our videoclip: https://stream.mux.com/e3QSBTjOZr6SSikxPrexy1RhLgUa2bq2jk0000v4nPtGQ.m3u8

1 Like

Great, that looks much better.